System Requirements

The system requirements outline the operating systems and browsers that you may use with Viewpoint for Projects™. Depending on your system, you may need to make additional configurations.

A majority of the functionality in Viewpoint for Projects™ will work on any browser. However, we recommend using Google Chrome or Internet Explorer as your browser for the best user experience. If you are using Internet Explorer, we recommend using Internet Explorer 10 or higher.

Restriction: Viewpoint for Projects™ is no longer tested against or developed for IE 7 or 8. Any issues specific to these versions of IE will not be addressed and new functionality may not be compatible.

If you use Internet Explorer, you must configure your browser to allow 4Projects popups and to accept 4Projects as a trusted site. In addition, you need to verify a specific security setting.

The table below lists the compatibility of specific operating systems and browsers with the Viewpoint for Projects™ web application versus the desktop app. In addition, the table lists the compatibility of operating systems and browsers with specific features.

  Windows 8 or higher Windows 7 Windows XP, Vista Mac OS Linux MS Edge IE 11 Google Chrome
Viewpoint for Projects™
Desktop App x x x N/A N/A N/A
Uploading multiple files x IE11
ActiveX View and Markup x x x
Flash View and Markup (to be retired in May 2017)
HTML View and Markup IE 11
Batch Print x x x
Explorer Plugin x x N/A N/A N/A
Outlook Plugin x x N/A N/A N/A
IFC Viewer IE11